Exchange 2010 SP2-Update

Am Wochenende waren die Exchange-Server dran, auf das SP2 aktualisiert zu werden.
2-3 Stolpersteine sind mir dabei in den Weg gekommen, die ich hier noch einmal zusammenfasse.
Ein Überblick über die wesentlichen Neuerungen – z.B. hier oder eben hier. Interessant ist z.B. oma (outlook mobile access) – gut für Smartphones mit kleinem Display und geringerer Bandbreite.

Zur Vorbereitung des Updates natürlich vorab ein ausführlicher Blick auf die Requirements, die Sicherstellung eines aktuellen Backups und schonmal der Start des Download des Pakets. Sind immerhin über 500 MB.
Zur Installation sollte man am Exchange-Server als Schema-Admin angemeldet sein, da wieder einmal das AD-Schema erweitert wird. Weiterhin ist es ratsam, vor Beginn der Installation alle tangierenden Dienste zu prüfen. Backup-Agent oder Virenscanner für Exchange zum Beispiel müssen vor Start des Setups beendet werden. Gern sind auch Drittanbieter-Tools für Gruppenkalender oder andere Collaborations-Programme involviert. Diese sollten zumindest für anschließende Funktionstests auf dem Zettel bleiben. 😉
Ist alles angerichtet, kann das Upgrade über die setup.exe aus dem entpackten Downloadfile starten.
Glücklicherweise prüft das Setup dann vorher noch einmal genau die Systemvoraussetzungen. Wenn diese soweit erfüllt sind, kann der Klick auf „Upgrade“ passieren. Jetzt wird das Schema erweitert, Exchange vorübergehend teilweise deinstalliert und neu installiert. Eine kleine Schrecksekunde war auf der Hälfte der Strecke ein „Error“ mit Abbruchmeldung, die sich bei näherem Hinschauen nur zu einer Neustartanforderung entpuppte. Nach diesem Neustart geht’s weiter mit einem erneuten Aufruf der setup.exe.
Alles in Allem hat der ganze Vorgang bei einem Server etwa 45 Minuten gedauert.

Anschließend der obligatorische Blick ins Eventlog, Start der abgeschalteten Dienste, Management-Konsole öffnen, Client-Zugriff testen, usw. Ich bin dann so vorgegangen, dass ich dann den/die restlichen Exchange-Server aktualisiert habe, als ich geprüft hatte, dass es keine größeren Probleme gab.

Nun die Fehler im Eventlog korrigieren…da waren gleich einige. Zunächst EventID 2937 von der Quelle MSExchange ADAccess. Der Fehler wird aber schon seit SP1 auftauchen. Beseitigung durch folgende CmdLets

Get-Recipient | Update-Recipient

Quelle: MSXFAQ.DE

Dann der Nächste. Warnung von der Quelle ASP.NET 2.0.50727.0 mit EventID 1309. Mmh, den kannte ich schon von irgendwoher. Zunächst konnte ich keine sichtbaren Probleme erkennen, bis ich den Hinweis bekam, dass im Outlook eines Benutzers der Abwesenheitsassistent nicht geöffnet werden konnte. Fehlermeldung (bei Outlook 2007):

„Ihre Abwesenheitseinstellungen können nicht angezeigt werden, da der Server zurzeit nicht verfügbar ist. Versuchen Sie es später erneut“.

In Outlook 2010 ähnlicher Wortlaut. Nach etwas Suchen bin ich dann auf folgender Seite dahintergekommen, dass es sich um einen bislang ungefixten Bug im SP2 handelt. Beeinträchtigt sind alle das EWS bezogenen Dienste, Frei-/Gebucht-Zeiten oder Lync-Konnektivität. Aber mittlerweile gibt es einen Workaround, da Microsoft die Ursache ermitteln konnte: Postfach-Datenbanken sollten keine runden Klammern in ihrer Bezeichnung besitzen. 😉

Auf einem zweiten Server kam beim Zugriff auf den Outlook Web Access (OWA) ein Fehler, worauf ich in den Authentifizierungs-Eigenschaften der Webseite im IIS den ASP.NET-Identitätswechsel wieder ausschaltete, der sich offenbar mit dem Upgrade aktiviert hatte.

Auch der Start der Exchange-Management-Shell auf einem der Server brachte eine Fehlermeldung:

„Der WinRM-Client kann die Anforderung nicht verarbeiten. Der Inhaltstyp der HTTP-Antwort vom Zielcomputer kann nicht ermittelt werden. Der Inhaltstyp fehlt oder ist ungültig.“

Hier war ebenfalls der IIS und die virtuelle Seite der PowerShell der Ansatzpunkt.
Bereich „Authentifizierung“ in der IIS-Verwaltungskonsole, aktivieren der anonymen Authentifizierung für diese Webseite behob diesen letzten Fehler.

2 Antworten auf „Exchange 2010 SP2-Update“

  1. Servus
    Habe gerade das selbe Problem Exchange 10 auf SP 2.Ergebniss schlaflose Nächte und Abwesenheitsassisten funktioniert nicht mehr. Das mit den runden Klammern ist hoffentlich ein schlechter WItz =) von Microsoft
    „ITS NOT A BUG , ITS A FEATURE!“

Kommentar verfassen